dual wan load balancing Mikrotik with PPPOE & Hotspot services

Spread the love

Hello Friends today i am sharing two wan dual load balancing with PPPoE & Hotspot Serves

Lets start with the help of Winbox open your Router

Remove All Configuration

Step No1

Now Change Port Name

1st Port name WAN1

2nd Port Name WAN2

Now change 3,4,5 port Name

Lan 1

Lan2

Lan3

now Got to Bridge to make all 3 LAN to bridge

Click on Bridge then Click on Bridge now + sign add bridge port

now go to port option

Now Select Port LAN1 and press ok button

step by step change LAN 2 and 3 to bridge and click OK button

Now Go to IP then go to address

NOW + OPTION

IN THE INTERFACE SECTION SELCET WAN1

NOW AD IP 192.168.10.10/24

CLICK OK

REPEAT AGAIN THIS STEP NOW SELECT WAN 2

AND GIVE THIS IP 192.168.11.11/24

NOW LOCAL NETWORK WE ASSIGN THIS 192.168.50.1/24

Select the bridge PORT

now go to IP option , firewall and NAT

On the NAT option add Rule

Chain remain same in the Out. Interface

Select WAN1

Now got to action option now select masquerade

Now repeat this step again now select on Out interface select WAN2

and then action select masquerade

Now the next step is go to Routes

select + option add new this getaways 192.168.10.1

the 2nd Getaways is 192.168.11.1

Now load Balance work complete

now you can configure you PPPOE and Hotspot Service

dual wan load balancing Mikrotik script Free Download

Click On Download Button to Download dual wan load balancing Mikrotik Script

Download

How to Configure dual wan load balancing Mikrotik with PPPOE & HOTSPOT

Watch this Video

How to Configure Mikrotik Router Dual WAN with Text script

Open Your Router Board with the help of Winbox

Go to New Terminal

Now press enter key

copy all Text and Past in New Terminal

after Few second Your router Board is convert in new installation Dual wan load balancer with full setting Hostspot and PPPOE serives




Dual Wan load Balancer full setting text script

Copy all Text and past in New Terminal

/interface bridge
add name=bridge1
/interface wireless
set [ find default-name=wlan1 ] ssid=MikroTik
/interface ethernet
set [ find default-name=ether3 ] name=LAN1
set [ find default-name=ether4 ] name=LAN2
set [ find default-name=ether5 ] name=LAN3
set [ find default-name=ether1 ] name=WAN1
set [ find default-name=ether2 ] name=WAN2
/interface pppoe-server
add name=pppoe-in1 service=”” user=””
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
add dns-name=airfiber.net hotspot-address=192.168.50.1 name=hsprof1
/ip pool
add name=hs-pool-8 ranges=192.168.50.1-192.168.50.254
add name=pppoe ranges=192.168.60.1-192.168.60.254
/ip dhcp-server
add address-pool=hs-pool-8 disabled=no interface=bridge1 lease-time=1h name=\
dhcp1
/ip hotspot
add address-pool=hs-pool-8 disabled=no interface=bridge1 name=hotspot1 \
profile=hsprof1
/ip hotspot user profile
add address-pool=hs-pool-8 name=1mb rate-limit=1m/1m transparent-proxy=yes
add address-pool=hs-pool-8 name=2mb rate-limit=2m/2m transparent-proxy=yes
/ppp profile
add local-address=192.168.50.1 name=2mb rate-limit=2m/2m remote-address=pppoe
add local-address=192.168.50.1 name=4mb rate-limit=4m/4m remote-address=pppoe
add local-address=192.168.50.1 name=1mb rate-limit=1m/1m remote-address=pppoe
/interface bridge port
add bridge=bridge1 interface=LAN1
add bridge=bridge1 interface=LAN2
add bridge=bridge1 interface=LAN3
/interface pppoe-server server
add authentication=pap disabled=no interface=bridge1 one-session-per-host=yes \
service-name=service1
/ip address
add address=192.168.10.10/24 interface=WAN1 network=192.168.10.0
add address=192.168.11.11/24 interface=WAN2 network=192.168.11.0
add address=192.168.50.1/24 interface=bridge1 network=192.168.50.0
/ip dhcp-client
add disabled=no interface=WAN1
add disabled=no interface=WAN2
/ip dhcp-server network
add address=192.168.50.0/24 comment=”hotspot network” gateway=192.168.50.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,4.4.4.4
/ip firewall filter
add action=passthrough chain=unused-hs-chain comment=\
“place hotspot rules here” disabled=yes
/ip firewall nat
add action=passthrough chain=unused-hs-chain comment=\
“place hotspot rules here” disabled=yes
add action=masquerade chain=srcnat out-interface=WAN1
add action=masquerade chain=srcnat out-interface=WAN2
add action=masquerade chain=srcnat comment=”masquerade hotspot network” \
src-address=192.168.50.0/24
add action=masquerade chain=srcnat comment=”masquerade hotspot network” \
src-address=192.168.60.0/24
/ip hotspot user
add name=admin password=khan
add name=test password=1234 profile=2mb
/ip route
add distance=1 gateway=192.168.11.1,192.168.10.1
/ppp secret
add name=asif password=1234 profile=2mb service=pppoe
add name=net password=1234 profile=1mb service=pppoe
add name=itshop password=1234 profile=4mb service=pppoe
add name=it password=1234 profile=2mb service=pppoe
/system clock
set time-zone-name=Asia/Karachi

Keyword Tags dual wan load Balancer

mikrotik load balancing over multiple gateways,

mikrotik dual wan failover,

mikrotik load balancing 2 wan pppoe,

mikrotik load balancing 3 wan,

how to combine 2 isp connections mikrotik,

mikrotik multiple gateways,

mikrotik bonding 2 wan,

mikrotik mark-routing dual wan,