how to configure Mikrotik router step by step

Spread the love

Hello Friend to I am going to tell you how to configure Mikrotik router step by step with the help of Video Tutorial

how to configure Mikrotik router step by step

how to configure Mikrotik router step by step

PPPoE & Hotspot full-text script

Copy this text script and past in New terminal

/interface bridge
add name=bridge1
/interface pppoe-server
add name=pppoe-in1 service=”” user=””
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
add dns-name=airfiber.net hotspot-address=192.168.88.1 name=hsprof1
/ip pool
add name=hs-pool-7 ranges=192.168.88.2-192.168.88.254
add name=PPPOE ranges=192.168.78.2-192.168.78.254
/ip dhcp-server
add address-pool=hs-pool-7 disabled=no interface=bridge1 lease-time=1h name=\
dhcp1
/ip hotspot
add address-pool=hs-pool-7 disabled=no interface=bridge1 name=hotspot1 \
profile=hsprof1
/ip hotspot user profile
add address-pool=hs-pool-7 name=1MB rate-limit=1m/1m transparent-proxy=yes
/ppp profile
add local-address=192.168.88.1 name=1mb rate-limit=1m/1m remote-address=PPPOE
add local-address=192.168.88.1 name=2mb rate-limit=2m/2m remote-address=PPPOE
add local-address=192.168.88.1 name=4md rate-limit=4m/4m remote-address=PPPOE
/interface bridge port
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
/interface list member
add interface=ether1 list=WAN
add interface=bridge1 list=LAN
/interface pppoe-server server
add authentication=pap disabled=no interface=bridge1 one-session-per-host=yes \
service-name=service1
/ip address
add address=192.168.88.1/24 interface=ether2 network=192.168.88.0
/ip dhcp-client
add disabled=no interface=ether1
/ip dhcp-server network
add address=192.168.88.0/24 comment=”hotspot network” gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
/ip firewall filter
add action=passthrough chain=unused-hs-chain comment=\
“place hotspot rules here” disabled=yes
/ip firewall nat
add action=passthrough chain=unused-hs-chain comment=\
“place hotspot rules here” disabled=yes
add action=masquerade chain=srcnat comment=”masquerade hotspot network” \
src-address=192.168.88.0/24
add action=masquerade chain=srcnat comment=”masquerade hotspot network” \
src-address=192.168.78.0/24
/ip hotspot user
add name=admin password=khan
/ppp secret
add name=it password=1234 profile=2mb service=pppoe
add name=asif password=1234 profile=2mb service=pppoe
add name=net password=1234 profile=1mb service=pppoe
add name=itshop password=1234 profile=4md service=pppoe
add name=khan password=1234 profile=4md service=pppoe
/system clock
set time-zone-name=Asia/Karachi
/system identity
set name=University

Download PPPoE & hotspot script

Download